Back to overview
Degraded

EU Region 1 is Degraded

Feb 01 at 11:35am UTC
Affected services
Google Apps

Resolved
Feb 01 at 11:37am UTC

The situation has been resolved.

Created
Feb 01 at 11:35am UTC

Due to the issues with the switch, the EU Region 1 is degraded currently.